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Installing  Teaching.Codes  

This document describes the steps for installing the Teaching.Codes plug-in for Eclipse as the requirement for 

programming courses. The system requires Java8, Eclipse IDE for Java Developers, and Teaching.Codes Eclipse 

plugin for all users including C/C++, and Python students.  

Table of Contents 

1. Installing the Java 8 JDK...................................................................................................................... 2 

1.1. Using Java 8 Without Installing ........................................................................................................ 2 

1.2. Installing Java8 on Linux .................................................................................................................... 2 

1.3. Installing Java8 on Windows ............................................................................................................. 2 

1.4. Installing Java8 on MacOS .................................................................................................................. 3 

1.5. Selecting the correct version of Java for Eclipse .......................................................................... 3 

2. Setting up Eclipse................................................................................................................................... 3 

3. Installing Teaching.Codes Eclipse Plugin ...................................................................................... 3 

4. Updating Teaching.Codes Eclipse Plugin ....................................................................................... 5 

5. Login and Password Update .............................................................................................................. 6 

6. Installing the C/C++ Development Environment ......................................................................... 6 

6.1. Linux: Installing GCC............................................................................................................................. 6 

6.2. Windows: Setting Up Cygwin ............................................................................................................. 6 

6.3. MacOS: Installing C ............................................................................................................................... 6 

7. Installing CDT for C/C++ Development ........................................................................................... 6 

8. Installing the Python Interpreter ..................................................................................................... 7 

8.1. Python in Linux....................................................................................................................................... 7 

8.2. Python in Windows ............................................................................................................................... 7 

8.3. Python in Mac OS ................................................................................................................................... 7 

9. Installing PyDev for Python Development ..................................................................................... 7 
 

 

  



 

(v20200220). 

 

1. Installing the Java 8 JDK 
The Eclipse platform requires a Java Virtual Machine to be present in your system, even if you are going to 

develop only in C/C++, Python or other languages. Teaching.Codes plugin and the server system is currently 

compatible with Java version 8, which is regularly being updated. Either of the OpenJDK 

(https://openjdk.java.net/install/) or Oracle JDK can be used. 

You should install the Java 8 Development Kit (JDK) and NOT the Java Runtime Environment (JRE).  

If you are a Linux or Windows user having a different version of Java installed on your system, which you do not 

want to change for any specific reason,  Java 8 can still be used without installing on the system. However Mac 

OS users will have to install the Java 8 alongside with their current Java.  

1.1. Using Java 8 Without Installing 
 

This method only works in Linux and Microsoft Windows systems, and not in Mac OS. 

You need to download the specific  JDK 8 package for your operating system. Then only the contents of the  

package should be extracted into a folder named exactly as “jre”, with no capital letters. The extraction process 

may be different based on the operating system. The contents of that jre folder should look similar to   

jre/bin 

jre/include 

jre/lib  

etc.  This folder will be necessary in later steps. The jdk package also includes a jre folder, so jre/jre is OK and 

it should not be removed. 

1.2. Installing Java8 on Linux 
For Debian, Ubuntu, etc., on the command line, you should type:  

sudo apt-get install openjdk-8-jdk 

For Fedora, Centos, Oracle Linux, Red Hat Enterprise Linux, etc.,  on the command line, you should type: 

su -c "yum install java-1.8.0-openjdk-devel" 

To verify that Java is properly installed, the you can open a terminal and run the command below: 

 java -version 

The output should explicitly state the version as “8.*.*” or “1.8.*” where any other version number can be present 

instead of ‘*’. The most recent version of Java 8 must be used. 

Necessary information can be found in Oracle JDK 8 download site for installing that version. 

1.3. Installing Java8 on Windows 
Content will be uploaded. 

https://openjdk.java.net/install/
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1.4.  Installing Java8 on MacOS 
Content will be uploaded.  

1.5. Selecting the correct version of Java for Eclipse 
Content will be uploaded.  

2. Setting up Eclipse 
Now that you have everything ready to install Eclipse. There are different versions of Eclipse available for 

different programming environments. However, you should install the  

“Eclipse IDE for Java Developers” version, and you will add necessary components in later steps.  

The Eclipse project is continuously being updated, you should download the most recent version from the Linux 

64-bit download link of the Eclipse IDE for Java Developers section of 

https://www.eclipse.org/downloads/packages/ 

Once you download and extract the Eclipse package, you can run the eclipse application located in the eclipse 

folder. Eclipse will ask for a workspace location to store your project files. You need to specify a folder, which 

will be created for you if it does not exists. However you will need to remember that location for later steps in 

this manual and during your project development. There is a special header you need to include in your 

workspace. It is better to use the workspace you can download from 

http://programming.cmpe.boun.edu.tr/downloads/workspace.zip . Please extract this package to a relevant 

location and use it as your workspace in Eclipse, as explained above. 

For those who decided not to install the JDK 8 package as explained above, you need to move the jre folder right 

into the eclipse folder, and run the application afterwards. This way you will prevent eclipse from using the pre-

installed java version in your system, and use the java 8 package. This method also works in Microsoft Windows 

systems as well.  

3. Installing Teaching.Codes Eclipse Plugin 
 

1. In Eclipse IDE, select Install New Software from the  Help menu.  
2. A window with a title “Install” will pop-up,  click the “Add” button on the window 
3. Type Teaching.Codes to the Name field 
4. Copy and paste http://programming.cmpe.boun.edu.tr/downloads/StudentPlugin to the Location 

field. 

https://www.eclipse.org/downloads/packages/
http://programming.cmpe.boun.edu.tr/downloads/workspace.zip
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5. Click “Add” button on the smaller pop-up. 

 
 

6. You will now see an entry on the “Install” window similar to “Teaching.Codes Student Plugin”, select 
the checkbox next to that entry. 

 
 

7. Click “Next” button one or more times to move on.  
8. Then you will be asked to accept a license agreement,  
9. Click “Finish” button. 
10. Restart Eclipse if asked to do so. 
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11. When the Eclipse is restarted you may have to select  
Window -> Show View -> Other -> Teaching.Codes -> Teaching.Codes Main from the Eclipse menu 
and the following pop-up windows.  

12. You should be able to see the Teaching.Codes Main and Teaching.Codes Browser panels.  

 

4. Updating Teaching.Codes Eclipse Plugin 
 

You may be asked to update your Teaching.Codes plugin during the semester by your instructors,  simply select 

Help -> Check For Updates from the Eclipse menu, and progress accordingly.  

If Eclipse does not list the most recent version of the plugin as told by your instructor, that means your Eclipse 

cache is not up to date for some reason, to update the cache: 

1. Select Help-> Install New Software -> Manage from the Eclipse menu. 
2. Select the entry similar to Name “Teaching.Codes” as you have typed above, having the Location value 

http://programming.cmpe.boun.edu.tr/downloads/StudentPlugin  
3. Click the Reload button. 

 
4. Close all pop-up windows and check for updates from, Help -> Check For Updates menu 
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5. Login and Password Update 
If you have received the login information in your email, you can use that to login to the system. For example: 

Institution Name : boun-cmpe 

Server Address : https://programming.cmpe.boun.edu.tr 

Username: your username 

Password: your password 

The Institution Name and Server Address may differ for other departments, such as boun-swe. You may change 

your password using the “Change Password” section of the plugin, as well as the “User Menu/Change 

Password” link on the web page https://programming.cmpe.boun.edu.tr. You may request a verification code 

to be sent to your e-mail address, if you do not remember your current password.  

It is your responsibility to use a password that you can remember, which will also be necessary during the exams. 

You may not be able to change your password during the exam sessions. 

6. Installing the C/C++ Development Environment 
Depending on your operating system, you may install the relevant compiler as follows: 

6.1. Linux: Installing GCC 
If you are going to develop programs in C/C++ then you will need the C compiler, you may skip this step 

otherwise.  

Linux distributions typically have the GCC compiler pre-installed, so you may not need to do anything for this 

stage in Linux. Please type “gcc -v” in a terminal to make sure. If it is missing, use your package installer (yum, 

apt, etc.) to install GCC.  

6.2. Windows: Setting Up Cygwin 
Content will be uploaded. 

6.3. MacOS: Installing C 
Content will be uploaded. 

7. Installing CDT for C/C++ Development 
Eclipse needs CDT for developing C/C++ projects.  

1. Select Help -> Eclipse Market Place 
2. Type cdt in the Find search field. 
3. Click Go button, or simply hit the return/enter button on your keyboard. 
4. Click the Install button of the listed Eclipse C/C++ IDE … entry, the name may not be exact, but a 

similar search result will be listed indicating the C/C++ development environment. 
5. CONFIGURATION For Windows, (Content will be uploaded) 
6. CONFIGURATION For MacOS, (Content will be uploaded) 

https://programming.cmpe.boun.edu.tr/
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8. Installing the Python Interpreter 

8.1. Python in Linux 
If you are going to develop programs in Python then you will need the Python interpreter,  you may skip this 

step otherwise.  

Linux distributions typically have the Python interpreter pre-installed, so you may not need to do anything for 

this stage in Linux. Please type “python --version” in a terminal to make sure. If it is missing, use your 

package installer (yum, apt, etc.) to install python.  

8.2. Python in Windows 
Content will be uploaded. 

8.3. Python in Mac OS 
Content will be uploaded. 

9. Installing PyDev for Python Development 
Eclipse needs PyDev for developing Python projects.  

1. Select Help -> Eclipse Market Place 
2. Type pydev in the Find search field. 
3. Click Go button, or simply hit the return/enter button on your keyboard. 
4. Click the Install button of the listed PyDev - Python IDE for Eclipse … entry, the name may not be 

exact, but a similar search result will be listed indicating the Python development environment.  
7. CONFIGURATION for Linux, (Content will be uploaded) 
8. CONFIGURATION for Windows, (Content will be uploaded) 
9. CONFIGURATION for MacOS, (Content will be uploaded) 
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